21 Kwietnia 2024 09:56:28
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· konfiguracja router ...
· Szukam zaproszenia n...
· [Howto] Xpenology na...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· Jaki USB hub do syno...
Najpopularniejsze obecnie wątki
· [Howto] Xpenology... [21]
· Szukam zaproszeni... [16]
· dodatkowe złącz... [4]
· konfiguracja rout... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.238.71.155
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-ARM - wątek deweloperski
qwerty321
No to wykryłem, że nawala jak włączyli jeden z komputerów :-) Na szczęście nie działał całą dobę. Są takie urządzenia jak UTM ale drogie i trzeba płacić abonament, np Stormshield. Cena początkowa to 6000 PLN. Jest darmowy opnsense ale z kolei wymaga osobnego komputera z dwoma ethernetami lan-wan. Dodatkowa płytka, Raspberry nie ma 2 eth i jest niepewne. Ten wirus mnie zdziwił, że nie zaszyfrował dysku tylko wysyłał spam i jakieś wałki usiłował robić.
Np by się przydało obserwowanie portów 25, 465, 993, 995, 110 albo definiowanych przez użytkownikach. Można by też liczyć ilość sesji HTTPS na jedno IP i w razie czego zablokować to IP. Wirus by musiał udawać człowieka.

[url]
https://opnsense.org/
[/url]
Edytowany przez qwerty321 dnia 28-06-2020 06:08
 
Marco76
Porządna firma powinna mieć porządną sieć i firewall. Tak, trzeba płacić, albo za usługę, albo adminowi jaki będzie to wszystko ogarniał ręcznie, dzień w dzień. Plus odpowiednia konfiguracja, a nie że wszystkie urządzenia w sieci wszystko mogą i do wszystkiego mają dostęp. Amatorka i pozorne oszczędności tak się właśnie kończą.
Wątpię, aby na Tomato udało się uruchomić analizę ruchu w locie z prawdziwego zdarzenia. Darmiwe opnsense czy pfsense do rozszywania ruchu też potrzebują sporego CPU, czyli maszynki za 1,5k+ z i5 lub i7 na pokładzie.
PS. To nie jest chyba odpowiedni wątek na takie rozważania.
[small]Pozdrawiam, Monter
Asus RT-N18 + FreshTomato 2019.3 K26ARM USB AIO-64K-NOSMP + ILHM v2
HTPC Chieftec FLYER FI-02BC-U3 + GA-H61N-USB3 + i3-3225 + 4GB RAM + LibreELEC + Xbox DVD Remot
 
shibby

Cytat

shibby napisał(a):


W custom config wpisane:
route 10.1.1.2 255.255.255.255

i niestety routing nie jest dodawany.


Winowajca:
https://bitbucket.org/pedro311/freshtomato-arm/src/a289012122d98c4aaa13187d2b921f0a57d3ffa8/release/src-rt-6.x.4708/router/rc/openvpn.c#lines-314

Cytat

"up updown-client.sh\n"
"down updown-client.sh\n"


Choć dla świętego spokoju wywaliłem linie od 306 do 318 i skompilowałem. Teraz routing wpisany w custom config poprawnie się dodaje po starcie openVPN.

Mam świadomość, że to nie jest rozwiązanie. Mam świadomość, że może jakąś funkcję właśnie popsułem Wink Ale działa mi to co powinno i jak powinno i to dla mnie jest najważniejsze.
Wskazuję jedynie problem i kierunek jego rozwiązania. Aż dziw, że do tej pory nikt tego nie zgłosił, bo sprawdziłem najstarszą wersję wspierającą E1 czyli 2019.03 i na niej też ten problem występował.
Edytowany przez shibby dnia 29-06-2020 12:16
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
maxikaaz
Jak duży udział można podmontować pod CIFS...? Bez problemu montują się udziały o wielkościach 2TB i 3TB, a 8TB już nie.
Są jakieś ograniczenia, czy to bug?

Połączony z 30 czerwca 2020 19:14:34:

Cytat

maxikaaz napisał(a):

Jak duży udział można podmontować pod CIFS...? Bez problemu montują się udziały o wielkościach 2TB i 3TB, a 8TB już nie.
Udziały są na Zyxelu NSA325, router to R7000, Tomato 2020.3 AIO.
Są jakieś ograniczenia, czy to bug?

Edytowany przez maxikaaz dnia 30-06-2020 18:14
WL-500gPv1@128MB&OC300MHz, Tomato DualWAN
RT-N16, FT 2021.8
RT-AC56u, FT 2022.1
R7000, FT 2022.1
DIR868L=>RT-AC66u B1, FT 2022.1
ZyXEL NSA-310, GargoylePL
ZyXEL NSA-325v2, GargoylePL
 
amikot
Udział CIFS nie ma rozmiaru z punktu widzenia klienta.
Klient CIFS zajmuje się jedynie wysyłaniem lub odbieraniem plików do/z serwera. Z rozmiarem zasobu nie ma w ogóle styczności. Z rozmiarem pliku już tak, ale w tym wypadku ograniczeniem jest limit lokalnego filesystemu po stronie klienta lub/i pamięci.
Oczywiście klient nie może przekroczyć limitu serwera - np. jeśli udział na serwerze to dysk z FAT32 to klient nie będzie mógł zapisać pliku większego niż 4GB.
Jednak, mimo że sam CIFS nie ma ograniczeń to możliwe, że implementacja w tomato takie ograniczenie wprowadziła. Tomato odpytuje serwer o wielkość dostępnego miejsca i być może odpowiedź jest przechowywana jako integer a maksymalny rozmiar dla unsigned-int to 4,294,967,295 - czyli 4TB.
Możliwe że cały skrypt montowania się sypie bo ta jedna zmienna ulega przepełnieniu? Trzeba by było to sprawdzić.

Ja sam mogę jedynie zapewnić, że na moim Linksysie udział o rozmiarze 3,658.68 GB działa doskonale. Może w przyszłości dołożę jakiś dysk to NASa to się okaże co z tego wyjdzie Smile

Połączony z 03 lipca 2020 23:20:51:
A i jeszcze jedno. W pracy mamy Synology z bodaj 20TB RAIDem i jest też serwer linuxowy który nie ma problemu z zamontowaniem tego zasobu.
Działa doskonale - no ale ten serwer ma dużo aktualniejszy kernel - więc trudno porównywać do tomato - choć zważywszy na to jak CIFS klient działa to nie powinno raczej być różnicy.
Edytowany przez amikot dnia 03-07-2020 23:20
ZTE MF286D - Stock Firmware (Vodafone UK)
ASUS TUF-AX3000 V2 - AsusWRT/FreshTomato 3.0.0.4.2023_4-gb6923ed
Acer Aspire E1-571 - OMV 6
 
qrs
https://bitbucket.org/pedro311/fresht...sing-20203
dziwne, u mnie ten problem nie występuje
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
hsimpson
Z góry przepraszam jeśli pytam nie w tym wątku.
Czy w przyszłości będzie może wspierany TP-Link Archer AX11000 (http://en.techinfodepot.shoutwiki.com...er_AX11000)? Jest szansa?
Netgear R7000 - Tomato v1.28 K26ARM-137
Asus RT-N66U - Tomato v1.28 K26RT-N-137
Synology DS-212j - DSM 6.x
 
pedro
FreshTomato-ARM 2020.4 jest gotowe do pobrania. Więcej info w pierwszym poście:

https://openlinksys.info/forum/viewth...d_id=22134
Netowski 1Gb/1Gb
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
FreshTomato: Asus RT-AC3200 + RT-N18U + RT-N66U + RT-N12
 
man1
Przepraszam, nie chcę się czepiać, ale gdzie można znaleźć changelog dla 2020.4?

Czy problemy z openvpn o których pisał @Shibby udało się już rozwiązać?

Połączony z 10 lipca 2020 20:51:42:
Changelog juz dostepny Smile
dziękuję Smile)

Połączony z 10 lipca 2020 20:53:27:
Wg changeloga problemy z Ovpn rozwiazane.

To się biorę za testy ! Smile_)

Połączony z 10 lipca 2020 21:46:55:
Dziala Smile
ŁAdnie wygląda Wink
Edytowany przez man1 dnia 10-07-2020 21:46
 
amikot
Potwierdzam poprawne działanie 2020.4 na EA6900.
Konfiguracja z dyskiem USB, Entware i VPNem.

Wielkie dzięki Pedro !
Smile
ZTE MF286D - Stock Firmware (Vodafone UK)
ASUS TUF-AX3000 V2 - AsusWRT/FreshTomato 3.0.0.4.2023_4-gb6923ed
Acer Aspire E1-571 - OMV 6
 
overflow2
Potrzebuję zablokować możliwość logowania się na router dla urządzeń wpiętych do jednego bridge. Podpowie ktoś jak coś takiego uzyskać? - o ile się da...
Asus RT-AC56U FT-AIO
 
dudijack
Prosze o informację co zostało wycięte z obrazu dla Dlink DIR868L (rev A1/B1/C1). Mam możliwość zakupu tego modelu w zamian za już wysłuzony RT-N16. W szczególności zależy mi na obsłudze Bttorrent, a nie jestem pewny czy usługa ta jest funkcjonalna w obrazie dla dla tego routera.
 
man1
Potwierdzam działanie zgodnie z oczekiwaniami Smile
I dziękuję za kawał świetnej roboty.

Uptime 1 day, 14:17:54

I cały czas oram go po udziale SMB co we wcześniejszych wersjach powodowało restarty.

Naprawde jest super Smile
 
amikot

Cytat

overflow2 napisał(a):

Potrzebuję zablokować możliwość logowania się na router dla urządzeń wpiętych do jednego bridge. Podpowie ktoś jak coś takiego uzyskać? - o ile się da...


Jeśli to urządzenie które ma być zblokowane ma mieć dostęp do pozostałych urządzeń - to może być trudno. Jeśli tylko do bramy i internetu to będzie pewnie łatwiej.
Zacząć należałoby od utworzenia LAN2 w Advanced/VLAN i przypisanie mu adresów IP/DHCP w Basic/Network.
W Administration/Admin Access należy zmienić porty dla Local Access HTTP/HTTPS na coś innego niż standardowe 80/443 (na przykład 50501(http) i 50502(https) - port(y) te trzeba będzie używać od teraz w przeglądarce aby dostać się do konfiguracji.

Następnie należałoby ustawić IPtables aby blokowało dostęp do routera z LAN2 na ustawionych portach (blokada spowoduje również niemożność kożystania z tych portów do połączeń z internetem - dlatego niemożna użyć portów standardowych 80/443 bo blokując dostęp do strony z ustawieniami zablokowałbyś dostęp do stron w internecie.

Żeby zablokować ustawione porty należałoby Do Admin/Scripts/Firewall trzebaby dodać coś w kształcie:

iptables -I INPUT -i br1 --dport 50501 -j DROP
iptables -I INPUT -i br1 --dport 50502 -j DROP

Obie te komendy należy najpierw wypróbować w terminalu - nie ponoszę odpowiedzialności jeśli ktoś sobie zblokuje dostęp do routera Smile Teoretycznie mają one DROPić na wejściu wszystkie próby połączeń przychodzące z interfaceu br1 (LAN2) kierowane do portu 50501 i 50502.

Jeśli dodatkowo urządzenia z LAN2 miałyby gadać z tymi z LAN1 - to chyba trzeba by ustawić połączenia w LAN Access, ale jak to nie wiem.
ZTE MF286D - Stock Firmware (Vodafone UK)
ASUS TUF-AX3000 V2 - AsusWRT/FreshTomato 3.0.0.4.2023_4-gb6923ed
Acer Aspire E1-571 - OMV 6
 
qrs

Cytat

Blacon napisał(a):

Ruter R7000. Po aktualixacji do 2020.4 mam problemy z moim telefonami VoIP. Ktoś ma podobny problem?


Jakiś opis konfiguracji, logi? Brak opisu, nie ma problemu Smile
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
pedro
FreshTomato-ARM 2020.5 jest gotowe do pobrania (głównie poprawki błędów). Więcej info w pierwszym poście
Netowski 1Gb/1Gb
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
FreshTomato: Asus RT-AC3200 + RT-N18U + RT-N66U + RT-N12
 
qrs
pięknie działa, zero błędów Smile

dodałbym jeszcze width do

Cytat

textarea.as-script {
font: 12px monospace;
height: 400px;
overflow: scroll;
border: 1px solid #eeeeee;
}


aby textarea w Administration > Scripts na był 100% szerokości
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
amikot

Cytat

qrs napisał(a):

pięknie działa, zero błędów Smile

dodałbym jeszcze width do

Cytat

textarea.as-script {
font: 12px monospace;
height: 400px;
overflow: scroll;
border: 1px solid #eeeeee;
}


aby textarea w Administration > Scripts na był 100% szerokości



W Firefoxie jest na 100% szerokości.
ZTE MF286D - Stock Firmware (Vodafone UK)
ASUS TUF-AX3000 V2 - AsusWRT/FreshTomato 3.0.0.4.2023_4-gb6923ed
Acer Aspire E1-571 - OMV 6
 
qrs
W Firefoxie na Macu textarea jest zwężony, ale ręcznie dodałem external.css i już mam ok.
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
PanRatio
U mnie na AC56U z 2020.5 nadal nie da się korzystać.
Czyszczenie NVRAM i wszystkie ustawienia ręczne.
W telefonie WiFi raz jest w porządku, raz pojawia się ikona WiFi i LTE jednocześnie. Internet przestaje działać. Później ikonka WiFi znika i mam samo LTE i nagle po kilku sekundach znowu jest ikona WiFi. Oprócz tego regularnie się nie wczytują obrazki w aplikacji Wykopu. Na 2020.2 takich problemów nie mam.
Ale to nie wszystko.
Od kilku dni nie mogę kupić biletów na stronie https://rozklad-pkp.pl Po wyszukaniu połączenia i kliknięciu KUP BILET mam białą stronę https://bilet.intercity.pl/przekierowanie.jsp i nic więcej. Wyłączyłem adblocka i wszystkie wtyczki, czyściłem ciasteczka. Na końcu próbowałem innych, czystych przeglądarek i nic nie pomagało. Myślałem, że to awaria po stronie PKP, ale tak było od kliku dni więc nie sądzę, aby awaria trwała kilka dni. Wyłączyłem WiFi, połączyłem się po LTE i strona działa. Po włączeniu WiFi znowu nie działa. Strona zaczyna działać dopiero jak w DNS Server ustawię na Auto. Jak DNS Server ustawię na Manual i podam 1.1.1.1 oraz 1.0.0.1 albo 8.8.8.8 albo 8.8.4.4 to nie mogę kupić biletów na stronie PKP. Czemu?
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 12

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

tamtosiamto
19-03-2024 19:50
@Adooni 'Only one set is available for 1 band' i tak mam-1 set dla 2.4ghz i 1 dla 5ghz-czy czegos nie rozumiemW drugiej sieci goscinnej nie ma opcji wyboru Ruter only/ All nodes

Adooni
19-03-2024 19:14
no to przeczytaj to 2 pod - 1 stet z kazdego pasma jest dopuszczony na nody. zrob 2 siec jako goscinna na danym pasmie i wtedy sprawdz

71,215,059 unikalnych wizyt