28 Lutego 2024 17:15:46
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Banana PI (BRI-R3)
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· [MOD] FreshTomato-AR...
· Jaki USB hub do syno...
· [S] Karta sieciowa Q...
· Asus rt-n18u port fo...
· Netflix dzielenie ko...
· Nextcloud konfigurac...
· Netgear WNR3500L
· [MOD] FreshTomato-MI...
· [MOD] Tomato64 (x86-64)
· [S] ASUS RT-AC68U
· [S]Banana PI (BRI-R3...
· [S] Płyta, Procek, ...
· Czy to atak hakerski ?
· Asus RT-N10U - znany...
· asus rt-n10u problem...
· Konfiguracja adresó...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [865]
· Banana PI (BRI-R3) [21]
· Netflix dzielenie... [14]
· serwer VPN za wan'em [13]
· Nextcloud konfigu... [13]
· Jaki USB hub do s... [1]
· Przejscie z dyndn... [0]
· WDR3600 i problem... [0]
· [S] Karta sieciow... [0]
· Asus rt-n18u port... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [215 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 415
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
18.207.129.175
Zobacz wątek
OpenLinksys » :: ROUTERY :: » Asus
 Drukuj wątek
wl-500Gp + Atheros + Kamiakze 8.09
chrz
No głowy nie dam, że obie te rzeczy się nie zainstalowały, kmod-mac80211 na pewno mi sie gdzieś tam przewijał, wieczorem się upewnię jak jest z najświeższym trunkiem.
W sumie na 8.09.1 na pewno ich nie instalowałem a są:



root@OpenWrt:~# opkg list_installed | egrep 'apd|mac80211'
hostapd-mini - 0.6.6-1 -
kmod-mac80211 - 2.6.25.17+2008-08-06-brcm47xx-2 -


możne madwifi je dociągnęło...

Najbardziej mnie niepokoił ten kompletny brak informacji w dmesgu o tym, ze cos jest w pci... no nic nowy trunk nowa nadzieja :)


EDIT:

No nie bałdzo... :(

Pakiety sa od razu po wgraniu firmware:


root@OpenWrt:~# opkg list_installed | egrep 'apd|mac80211'
hostapd-mini - 0.6.9-1 -
kmod-mac80211 - 2.6.28.10+2009-06-25-brcm47xx-3 -


Po dorzuceniu ath9k:


root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/Packages.gz
Connecting to downloads.openwrt.org (195.56.146.238:80)
Packages.gz          100% |********************************************************************************************|   153k 00:00:00 ETA
Inflating http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/snapshots
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/snapshots/brcm47xx/packages/Packages
Connecting to downloads.x-wrt.org (88.198.39.176:80)
Packages             100% |********************************************************************************************|   812k 00:00:00 ETA
Updated list of available packages in /var/opkg-lists/X-Wrt

root@OpenWrt:~# opkg install kmod-ath9k
Installing kmod-ath9k (2.6.28.10+2009-06-25-brcm47xx-3) to root...
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/snapshots/brcm47xx/packages/kmod-ath9k_2.6.28.10+2009-06-25-brcm47xx-3_mipsel.ipk
Connecting to downloads.x-wrt.org (88.198.39.176:80)
kmod-ath9k_2.6.28.10 100% |********************************************************************************************|   122k 00:00:00 ETA
Installing kmod-ath (2.6.28.10+2009-06-25-brcm47xx-3) to root...
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/snapshots/brcm47xx/packages/kmod-ath_2.6.28.10+2009-06-25-brcm47xx-3_mipsel.ipk
Connecting to downloads.x-wrt.org (88.198.39.176:80)
kmod-ath_2.6.28.10+2 100% |********************************************************************************************|  6277  --:--:-- ETA
Configuring kmod-ath
Configuring kmod-ath9k


dmesg wyrzuca takie coś:


PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.0
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
CPU 0 Unable to handle kernel paging request at virtual address 00001080, epc == 8001a298, ra == 8001707c
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000b800 00001080 00001f9f
$ 4   : 00001080 00001f90 00000010 802a0000
$ 8   : 00000020 800050d0 00000003 81dee81c
$12   : 81c03680 ffffffff 0025e720 00260e30
$16   : 00001080 81df7b00 81c8a9d4 81c8aadc
$20   : 00000000 81968000 c07e0000 00000002
$24   : 00000002 80018860
$28   : 81ee2000 81ee3b68 7fc12e40 8001707c
Hi    : 00000018
Lo    : 00000083
epc   : 8001a298 0x8001a298
    Not tainted
ra    : 8001707c 0x8001707c
Status: 1000b803    KERNEL EXL IE
Cause : 00800008
BadVA : 00001080
PrId  : 00029006 (Broadcom BCM3302)
Modules linked in: ath9k(+) ath nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc b43legacy b43 mac80211 cfg80211 crc_ccitt arc4 aes_generic deflate ecb cbc cryptomgr crypto_hash crypto_blkcipher aead crypto_algapi switch_robo switch_core diag
Process insmod (pid: 1295, threadinfo=81ee2000, task=81c559d8, tls=00000000)
Stack : 81c8a9d4 81c8aadc 81970000 81c8a200 81970000 81a5ded8 c07e0000 81a5e70c
        81c8a080 00000020 00000200 00000001 81968090 81c8a200 81c8a9d4 00000000
        00000000 81a5c44c 00000000 00000020 81ee3bd4 0000a028 00000000 81a7ca20
        81c8a200 81401540 004953c4 00000002 00000008 8012d2a0 81a7d140 81c8a9d4
        81c8a200 81c294e4 00000000 81c29400 81a65114 81a650ac 800dc3d8 800dc39c
        ...
Call Trace:[<81a5ded8>] 0x81a5ded8
[<81a5e70c>] 0x81a5e70c
[<81a5c44c>] 0x81a5c44c
[<81401540>] 0x81401540
[<8012d2a0>] 0x8012d2a0
[<81a65114>] 0x81a65114
[<81a650ac>] 0x81a650ac
[<800dc3d8>] 0x800dc3d8
[<800dc39c>] 0x800dc39c
[<8015046c>] 0x8015046c
[<80133f14>] 0x80133f14
[<801225f8>] 0x801225f8
[<80153e8c>] 0x80153e8c
[<8021becc>] 0x8021becc
[<801540d4>] 0x801540d4
[<8015417c>] 0x8015417c
[<8015412c>] 0x8015412c
[<80150a80>] 0x80150a80
[<801532b4>] 0x801532b4
[<80119718>] 0x80119718
[<801017d4>] 0x801017d4
[<81a37000>] 0x81a37000
[<80153854>] 0x80153854
[<8015382c>] 0x8015382c
[<80101a24>] 0x80101a24
[<81a37000>] 0x81a37000
[<80154370>] 0x80154370
[<80101be8>] 0x80101be8
[<81a37000>] 0x81a37000
[<801341f0>] 0x801341f0
[<81a65664>] 0x81a65664
[<81a37068>] 0x81a37068
[<8000cdb4>] 0x8000cdb4
[<80185f00>] 0x80185f00
[<8009fdac>] 0x8009fdac
[<801b2e28>] 0x801b2e28
[<80119e44>] 0x80119e44
[<8005dea4>] 0x8005dea4
[<80079ddc>] 0x80079ddc
[<80051138>] 0x80051138
[<8012d8cc>] 0x8012d8cc
[<80043c44>] 0x80043c44
[<80051534>] 0x80051534
[<800514f8>] 0x800514f8
[<800872e4>] 0x800872e4
[<800031d0>] 0x800031d0
[<800031d0>] 0x800031d0


Code: 00a31821  00432824  00821024 10450007  00000000  00c21821  bc710000  00661821

Edytowany przez chrz dnia 27-07-2009 17:12
 
obsy
Wywalił Ci w kosmos system. Zostaje Ci ręczna kompilacja trunka, bo nie być może to co jest w snapshotach ma się nijak do Twojej wersji.

PS. Ale kartę znalazł :)
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
chrz
@obsy zrobiłem jak radziłeś i jest trochę lepiej:


PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.0
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
phy0: Selected rate control algorithm 'ath9k_rate_control'
Registered led device: ath9k-phy0::radio
Registered led device: ath9k-phy0::assoc
Registered led device: ath9k-phy0::tx
Registered led device: ath9k-phy0::rx
phy0: Atheros AR5416 MAC/BB Rev:2 AR2133 RF Rev:81: mem=0xc0220000, irq=6
cfg80211: Calling CRDA for country: US


Nawet Led od wifi się zapala po włączeniu radia :)

Tylko teraz się zastanawiam, bo nie jestem do końca pewien czy dobrze zrobiłem configa to co zmieniłem w stosuku do oryginalnego z svn-a to
- zmiana target-a na BCM947...
- target profile No wifi
- target images jffs2, squashfs
- w kernel modules -> wireless driver -> zaznaczyłem kmod-ath9k (built in)
- w Network dodałem hostapd-mini

Połączenie po wifi działa ( na razie testowałem nie szyfrowane ) ale na laptopie wyświetla tylko 54 i po przesłaniu pewnej ilości danych zaczyna się jakby podwieszać. Może jeszcze coś powinienem zmienić w configu, trochę jest goły... Kombinuje dalej :)
Edytowany przez chrz dnia 27-07-2009 20:23
 
obsy
target profile tylko zaznacza określone pakiety, wiec nie ma znaczenia. jffs2 nie jest Ci potrzebny. Reszta wg woli (iw i crda dla świętego spokoju, ale jak nie chcesz powyżej 11 kanalu to nie musisz).
To tyle.
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
chrz
Mały update, okazało się że laptop który ma tylko g działa bezproblemowo. Po dodaniu "option hwmode_11n g" do /etc/config/wireless w końcu na laptopie z n zobaczyłem, że łączy się z 80Mbps. Niestety dalej ma problem z łącznością, co ciekawe pingów do gatway-a w ogóle nie gubi dopiero na zewnątrz :/
 
chrz
Dla potomnych szperaczy powiem, ze nadal nici, jajko na tyle nowe na ile sie da z openwrt i guzik. Nie mam drugiej n-ki może eee ma problem, dwa inne g hosty przyklejone mocno.


root@OpenWrt:~# uname -a
Linux OpenWrt 2.6.30.3 #1 Thu Jul 30 01:24:35 CEST 2009 mips unknown


EDIT:

No w końcu się udało, użyłem bardzo świeżego compat-wireless-2009-08-01, usunąłem wszystkie patche openwrt dotyczące ath9k, poprawiłem 007-remove_unused_stuff.patch i pomimo, że doskonale jeszcze nie jest to mogę normalnie korzystać ze wszytkich urządzeń, które mają w domu wifi a eee ma w końcu n :) Czy było warto to już zupełnie inne pytanie ;)
Edytowany przez chrz dnia 02-08-2009 04:11
 
macmus

Cytat


No w końcu się udało, użyłem bardzo świeżego compat-wireless-2009-08-01, usunąłem wszystkie patche openwrt dotyczące ath9k, poprawiłem 007-remove_unused_stuff.patch i pomimo, że doskonale jeszcze nie jest to mogę normalnie korzystać ze wszytkich urządzeń, które mają w domu wifi a eee ma w końcu n Smile Czy było warto to już zupełnie inne pytanie Wink


da sie z tego zrobic jakiegos FAQ'a. Nigdzie na necie nie ma opisane jak krok po kroku zaintalowac sobie Atherosa z n supportem na ruterku WL500gP. Byłoby naprawde super takie cos do guida wrzucic Smile
 
swwitch
usunąłem pytanie,
po miesiącu czytania forum, wydało mi się strasznie głupie Wink
Edytowany przez swwitch dnia 07-09-2009 18:04
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 10

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

shibby
12-02-2024 11:03
MTU zależy od typu połączenia. Inne jest dla połączenia kablowego inne dla wdzwanianego (pppoe)

PanRatio
11-02-2024 10:02
Jak podłączę Funboxa6 do światłowodu, to ma MTU 1540, a we FreshTomato max to MTU 1500 i samo zmienia na 1492. Tak ma być?

tamtosiamto
04-02-2024 10:36
jakby cos, to mam w dobrej cenie dir868l juz przerobiony na AC66U_B1 Grin i ac56u przerobiony na ac68u(dziala aimesh) tyle ze z wlacznikiem na zapalke Smile

Adooni
03-02-2024 10:36
widze ze oba sa na aledrogo i u nas mozesz sprawdzac w dziale sprzedam

Adooni
03-02-2024 10:34
zakladam że mowisz o używkach masz np Asus RT-AC56U, D-Link DIR-868L (jak go nie przerobisz na Asus RT-AC66U_B1) to FT ma specialny build nvram 32k)

vechio
01-02-2024 09:29
Cześć, czy istnieje jakiś 'odpowiednik'
; WNR3500Lv2 z 5GHz i z TYLKO wewnętrznymi antenami + ze wsparciem dla FreshTomato?

tamtosiamto
29-01-2024 21:59
to linux, raczej nie masz tak duzego, ktorego nie obsluzy

RaTaJ
28-01-2024 23:08
Dzień Dobry jaki max dysk USB można podłączyć pod NetGear WNRL3500Lv2?

Adooni
01-01-2024 09:44
Wszystkiego najlepszego w nowym roku. Jaka macie sprawdzoną antenkę do E3372S?

Adooni
25-12-2023 08:34
ja kupilem ale ostatecznie oddalem i wzialem Cudy WR3000. Bardzo dobrze dziala z OpenWRT zabawy jest z wi-fi aby znalesc kanal ktory dziala na 160. Nowyszy HW w porownaniu do x6 i 2 razy mniejszy

69,640,816 unikalnych wizyt