21 Kwietnia 2024 09:44:16
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· konfiguracja router ...
· Szukam zaproszenia n...
· [Howto] Xpenology na...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· Jaki USB hub do syno...
Najpopularniejsze obecnie wątki
· [Howto] Xpenology... [21]
· Szukam zaproszeni... [16]
· dodatkowe złącz... [4]
· konfiguracja rout... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.238.71.155
Zobacz wątek
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj wątek
Torrenty na tomato - transmission
pepe_lodz
no to chyba nie mam otwartego porty bo mam taki komunikat :(


Checking port 51515 on 81.219.xx.xx...

   An error has occurred!

An error has occurred!

   Port 51515 does not appear to be open.

   Please see www.portforward.com for more information if you need to map


w firewall wpisalem tkie komendy


iptables -t nat -A PREROUTING -p tcp -d $WANIP --dport 51515 -j DNAT --to 192.168.2.1:51515
iptables -A INPUT -d 192.168.2.1 -p tcp --dport 51515 -j ACCEPT

Edytowany przez pepe_lodz dnia 18-09-2009 09:21
ASUS RT-AC88U 3.0.0.4.380-2064
ASUS RT-AC87U 3.0.0.4.380-1394
NAS Synology DS713+ + Server TVHEADEND 4.1.1533
Raspberry Pi 2 + Home Automation System Domoticz
 
shibby
nie masz otwartego portu bo przeciez jestes 2x za natem. nie masz publicznego ip. zrobiles sobie siec w sieci. admin/provider musial by ci odblokowac porty.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
pepe_lodz
no wiec co nie bedzie mi dobrze sciagac torrentow ? wiesz to jakos idzie ale wolno bardzo czesto
ASUS RT-AC88U 3.0.0.4.380-2064
ASUS RT-AC87U 3.0.0.4.380-1394
NAS Synology DS713+ + Server TVHEADEND 4.1.1533
Raspberry Pi 2 + Home Automation System Domoticz
 
grzechu84

Cytat

shibby napisał/a:
[quote]Mam pytanko, która linika w settings.json [transmission] jest odpowiedzialna za kolejkowanie. Chciałbym wrzucić np. 8 torcików ale żeby jednocześnie tylko jeden się pobierał.


transmission nie posiada takiej opcji.

Shibby, skoro transmission nie posiada takiej opcji, choć się na tym nie znam to zrobię do tego amatorski skrypt.
Proszę tylko o info gdzie znajdę tablicę cron'a.

Skrypt:
W katalogu torrent jest 1 plik torrent aktualnie pobierany. Jak kończy się pobieranie on w tym katalogu nadal jest, a pod tą samą nazwą tylko z innym rozszerzeniem tworzy się plik w katalogu resume.
Cron będzie badał co 10-20 min czy jest jakiś plik w katalogu resume. Jeśli tak to go usunie jak i również plik z katalogu torrent. Następnie z wcześnie utworzonego katalogu np: queue będzie przenosił plik torrent do katalogu torrent, a pobieranie rozpocznie się automatycznie.
Dobra idea?

Dzięki!
Asus WL-500g Premium v.1 || Tomato version v1.27.8741 ND USB Extra
 
shibby
gotowy skrypt idzie znalezc na necie.

a cron w tomato to nic innego jak sheduler.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
obsy
Tragiczna Smile.

Dodawaj od razu z trybie paused, a skryptem uruchamiaj po prostu kolejny z nich (przez transmission-remote)
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
obsy
O wilku mowa: http://pastie.org/357236
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
ovner
Nie wiem co jest nie tak ale nikt nie pobiera odemnie z transmissiona danych :( przez cała noc była wystawiona pozycja, na stronie serwisu widnieje jako Dostępność TAK, lynx zwraca

Checking port 42411 on 87.xxx.xxx.xxx...

   OK!

OK!

   Port 42411 is open and accepting connections.

   You will be able to receive incoming BitTorrent connections.

cos jeszcze jest nie tak settings.joson wygląda następująco

{
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "dht-enabled": true,
    "download-dir": "\/mnt\/dane\/torrenty\/Downloads",
    "encryption": 0,
    "lazy-bitfield-enabled": true,
    "message-level": 2,
    "open-file-limit": 10,
    "peer-limit-global": 400,
    "peer-limit-per-torrent": 100,
    "peer-port": 42411,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": 0,
    "pex-enabled": true,
    "port-forwarding-enabled": true,
    "preallocation": 1,
    "proxy": "",
    "proxy-auth-enabled": false,
    "proxy-auth-password": "",
    "proxy-auth-username": "",
    "proxy-enabled": false,
    "proxy-port": 80,
    "proxy-type": 0,
    "ratio-limit": 3.0000,
    "ratio-limit-enabled": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-password": "haslo",
    "rpc-port": 9091,
    "rpc-username": "user",
    "rpc-whitelist": "127.0.0.1,172.168.1.2,172.168.1.3",
    "rpc-whitelist-enabled": true,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "umask": 18,
    "upload-slots-per-torrent": 5


Po odpaleniu utorrenta na PC ten sam plik na tym samym porcie 42411 po chwili są połączenia i zaczyna się seeding. Macie jakieś sugestie ??
TUF-AX5400 @ Firmware:388.1_0-gnuton1
RT-N16 @ FreshTomato Firmware 2023.3 MIPSR2 K26 USB VPN + Huawei e3372 no-hilink
www.speedtest.net/result/14587008641.png
 
shibby
mozesz spobowac zwiekszyc ilosc slotow na wysyl. i dla testow wylacz ograniczenie ratio. moze ono cos miesza.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
grzechu84
dzięki Shibby , dzięki Obsy Grin
Asus WL-500g Premium v.1 || Tomato version v1.27.8741 ND USB Extra
 
ovner
Kolejny problem :(
Mam problem z przekierowaniem portów w tomato.
W zakładce firewall mam wstawione

WANIP=$(nvram get wan_ipaddr)
iptables -t nat -A PREROUTING -p tcp -d $WANIP --dport 51413 -j DNAT --to 172.168.1.1:42411
iptables -A INPUT -d 172.168.1.1 -p tcp --dport 42411 -j ACCEPT

dodatkowo mam w port forwarding ustawione przekierowanie źródło 42411 cel 172.168.1.1 port 42411 , oraz źródło 42411 cel 172.168.1.2 port 42411 i wszystko narazie było OK ale po zaniku zasilania port już nie jest odblokowany na routerze, przekierowanie tego portu na kompa mam otwarte a na routere nie dlaczego.
Czy Word Warp ma byc zaznaczone ?
Już zmieniłem port dla pc na 42412 i ten jest otwaryty a na routerze 42411 nie :(
TUF-AX5400 @ Firmware:388.1_0-gnuton1
RT-N16 @ FreshTomato Firmware 2023.3 MIPSR2 K26 USB VPN + Huawei e3372 no-hilink
www.speedtest.net/result/14587008641.png
 
shibby
wywal port forwarding a w firewallu zostaw tylko to

Cytat


#torrent
iptables -A INPUT -p tcp --dport 42412 -j ACCEPT


ja tak mam i wystarczy do otwarcia porty.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
ovner
Dzięki pomogło działa.
Czyli teraz port 42412 jest otwarty dla wszystkich komputerów w sieci.
TUF-AX5400 @ Firmware:388.1_0-gnuton1
RT-N16 @ FreshTomato Firmware 2023.3 MIPSR2 K26 USB VPN + Huawei e3372 no-hilink
www.speedtest.net/result/14587008641.png
 
shibby
nie, dla routera Smile uzyles INPUT wiec wszystko co przychodzi do routera na ten port jest akceptowane. jakby to mialoby byc przekierowane na jakiegos kompa to uzywasz FORWARD i prerouting.
Edytowany przez shibby dnia 22-09-2009 21:24
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
hepilord
Dlaczego uparcie tomato pisze mi, ze nie ma pliku transsmision tam gdzie powinien byc?
Robilem wszystko zgodnie z opisem, po podaniu komendy:
/opt/etc/init.d/transmission start mam odpowiedz: not found
plik tam jest bo go widze np w tc. Co mam zrobic bo juz mi brakuje pomyslow?
 
shibby
masz basha zainstalowanego? ma plik prawo execute?
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
hepilord

Cytat

shibby napisał/a:
masz basha zainstalowanego? ma plik prawo execute?


Dzieki za zainteresowanie
tam mam, plik ma nadane prawa
 
shibby
pokaz ls -l /opt/etc/init.d
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
hepilord

Cytat

shibby napisał/a:
pokaz ls -l /opt/etc/init.d


-rwxr-xr-x 1 root root 183 Nov 5 06:13 transmission

nie wiem czy to wazne bo jestem troche ziolony w sprawach linuxa
ale w kroku:
Tworzymy plik startowy:

touch /opt/etc/init.d/transmission

mam komunikat
No such file or directory
jak sprawdzam przez tc to brakuje mi katalogu init.d
tworze go sobie w tc i robie dalej i wg opisu.
Efekt taki jak podalem czyli brak transmission (niby)
 
shibby
mkdir /opt/etc/init.d
touch /opt/etc/init.d/transmission

Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 14

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

tamtosiamto
19-03-2024 19:50
@Adooni 'Only one set is available for 1 band' i tak mam-1 set dla 2.4ghz i 1 dla 5ghz-czy czegos nie rozumiemW drugiej sieci goscinnej nie ma opcji wyboru Ruter only/ All nodes

Adooni
19-03-2024 19:14
no to przeczytaj to 2 pod - 1 stet z kazdego pasma jest dopuszczony na nody. zrob 2 siec jako goscinna na danym pasmie i wtedy sprawdz

71,214,710 unikalnych wizyt