22 Lutego 2024 08:58:56
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· serwer VPN za wan'em
· Nextcloud konfigurac...
· Netflix dzielenie ko...
· [MOD] FreshTomato-AR...
· Netgear WNR3500L
· [MOD] FreshTomato-MI...
· [MOD] Tomato64 (x86-64)
· [S] ASUS RT-AC68U
· Banana PI (BRI-R3)
· [S]Banana PI (BRI-R3...
· [S] Płyta, Procek, ...
· Czy to atak hakerski ?
· Asus RT-N10U - znany...
· asus rt-n10u problem...
· Konfiguracja adresó...
· Wi-Fi 160MHz
· USB LAN do TV
· RT-N16
· ASUS AX92U bootloop
· Tomato resetuje się...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [862]
· Netgear WNR3500L [737]
· Nextcloud konfigu... [13]
· Netflix dzielenie... [12]
· serwer VPN za wan'em [4]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [215 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 415
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.236.145.153
Zobacz wątek
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj wątek
Torrenty na tomato - transmission
grzechu84
Hej,

Zrobiłem narazie wszystko tak jak w opisie i działa jak trzeba :]

Zastanawiam się tylko po co co 3 procesy: (od restartu routera)
190 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
192 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
193 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent

Czy międzyinnymi potrzebna jest linijka w Scripts-Firewall:
"/opt/etc/init.d/transmission start" ? (po włączeniu routera nie startuje automatycznie wszystkiego co w /opt/etc/init.d/ ?)
Edytowany przez grzechu84 dnia 20-04-2009 13:06
Asus WL-500g Premium v.1 || Tomato version v1.27.8741 ND USB Extra
 
fjk8

Cytat

shibby napisał/a:
oczywiscie zmieniajac 192.168.1.1 na ip routera i 9091 na port zdalny ktory wpisales w settings


Oczywiscie, oczywiscie :) Niestety nic z tego ja mysle ze problem lezy gdzies indziej - choc na rouerze niewiele zmienialem. Sprawdzalem czy wogole wykonuja sie te skrypty - wykonuja sie. Podobny problem mam z amulem do ktorego nigdy nie moge sie dostac nawet z wewnatrz albo z swapem ktory nigdy nie chce sie wlaczyc ze skryptu. Nie ma jakiejs mozliwosci logowania wiekszej ilosci szczegolow ?

grzechu84: Mi tez odpalaja sie trzy procesy, a emul wlacza nawet cztery :)

p.s. Tak to wyglada po dopisaniu:


# iptables --list
Chain INPUT (policy DROP)
target     prot opt source               destination
DROP       0    --  anywhere             moje_ip
logdrop    0    --  anywhere             anywhere            state INVALID
ACCEPT     0    --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     0    --  anywhere             anywhere
ACCEPT     0    --  anywhere             anywhere
logdrop    0    --  anywhere             anywhere
ACCEPT     tcp  --  anywhere             moje_ip tcp dpt:9091
ACCEPT     tcp  --  anywhere             unknown             tcp dpt:9091

Chain FORWARD (policy DROP)
target     prot opt source               destination
ACCEPT     0    --  anywhere             anywhere
DROP       0    --  anywhere             anywhere            state INVALID
TCPMSS     tcp  --  anywhere             anywhere            tcp flags:SYN,RST/SYN tcpmss match 1461:65535 TCPMSS set 1460
ACCEPT     0    --  anywhere             anywhere            state RELATED,ESTABLISHED
wanin      0    --  anywhere             anywhere
wanout     0    --  anywhere             anywhere
ACCEPT     0    --  anywhere             anywhere
upnp       0    --  anywhere             anywhere
ACCEPT     0    --  anywhere             192.168.1.112

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain logdrop (2 references)
target     prot opt source               destination
LOG        0    --  anywhere             anywhere            state NEW LOG level warning tcp-options ip-options prefix `DROP '
DROP       0    --  anywhere             anywhere

Chain logreject (0 references)
target     prot opt source               destination
LOG        0    --  anywhere             anywhere            LOG level warning tcp-options ip-options prefix `REJECT '
REJECT     tcp  --  anywhere             anywhere            reject-with tcp-reset

Chain upnp (1 references)
target     prot opt source               destination

Chain wanin (1 references)
target     prot opt source               destination

Chain wanout (1 references)
target     prot opt source               destination

Edytowany przez fjk8 dnia 20-04-2009 14:32
 
shibby

Cytat

grzechu84 napisał/a:
Hej,

Zrobiłem narazie wszystko tak jak w opisie i działa jak trzeba :]

Zastanawiam się tylko po co co 3 procesy: (od restartu routera)
190 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
192 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
193 root 7132 S /opt/bin/transmission-daemon -g /mnt/disc0_1/torrent


bo tak ma byc Smile


Cytat

grzechu84 napisał/a:
Czy międzyinnymi potrzebna jest linijka w Scripts-Firewall:
"/opt/etc/init.d/transmission start" ? (po włączeniu routera nie startuje automatycznie wszystkiego co w /opt/etc/init.d/ ?)


nie nie startuje, linijka jest potrzebna.
Edytowany przez shibby dnia 20-04-2009 15:10
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
shibby
fjk8 powinno ci chodzic, ja mam tak:

Cytat


root@groov:/tmp/home/root# iptables -L
Chain INPUT (policy DROP)
target prot opt source destination
DROP 0 -- anywhere anywhere state INVALID
ACCEPT 0 -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT 0 -- anywhere anywhere
ACCEPT 0 -- anywhere anywhere
ACCEPT icmp -- anywhere anywhere
ACCEPT tcp -- 195.xx.xx.xx groov tcp dpt:ssh
ACCEPT tcp -- anywhere groov tcp dpt:https
ACCEPT tcp -- anywhere groov tcp dpt:9091
ACCEPT tcp -- anywhere groov tcp dpt:51413


gdzie groov to 192.168.0.1 (ip lokalne mojego routera). ip publiczne mam zmienne

oraz

Cytat

root@groov:/tmp/home/root# iptables -L INPUT -vnx
Chain INPUT (policy DROP 7291 packets, 562307 bytes)
pkts bytes target prot opt in out source destination
159 12340 DROP 0 -- * * 0.0.0.0/0 0.0.0.0/0 state INVALID
1151718 790529498 ACCEPT 0 -- * * 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
2958 532489 ACCEPT 0 -- br0 * 0.0.0.0/0 0.0.0.0/0
157 9878 ACCEPT 0 -- lo * 0.0.0.0/0 0.0.0.0/0
5 300 ACCEPT icmp -- * * 0.0.0.0/0 0.0.0.0/0
9 1896 ACCEPT tcp -- * * 195.xx.xx.xx 192.168.0.1 tcp dpt:22
133 6384 ACCEPT tcp -- * * 0.0.0.0/0 192.168.0.1 tcp dpt:443
22 1056 ACCEPT tcp -- * * 0.0.0.0/0 192.168.0.1 tcp dpt:9091
7473 375956 ACCEPT tcp -- * * 0.0.0.0/0 192.168.0.1 tcp dpt:51413


i w firewallu

Cytat

#transmission
iptables -t nat -A PREROUTING -p tcp --dport 9091 -j DNAT --to 192.168.0.1:9091
iptables -A INPUT -d 192.168.0.1 -p tcp --dport 9091 -j ACCEPT
iptables -t nat -A PREROUTING -p tcp ! -s 192.168.0.0/24 --dport 51413 -j DNAT --to 192.168.0.1:51413
iptables -A INPUT -d 192.168.0.1 -p tcp --dport 51413 -j ACCEPT


powiedz jakie masz ip WAN, napewno masz swoje ip publiczne a nie natowane u providera? mozesz zalogowac sie z zewnatrz na cokolwiek? np https, http, ssh???
Edytowany przez shibby dnia 20-04-2009 15:17
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
fjk8
Napewno mam publiczne glupi nie jestem Smile Mam to samo publiczne ip od wielu lat. Moge zalogowac sie na wszystko jak powlaczam - sprawdzalem to tez.

p.s. moge tez zalogowac sie z netu na ftp ktore mam na lokalnym kompie w dmz.
Edytowany przez fjk8 dnia 20-04-2009 16:09
 
grzechu84
fjk8 mi tez nic nie przychodzi do głowy jak rozwiązać Twój problem. Może to jakiś błachy problem.
Rozumiem, że masz tą samą konfigurację pliku "settings.json" jak w tutorialu i z zewnątrz wstukujesz http://ip_routera:9091/ nie pomijając części "http://" bez której napewno się nie dostaniesz?

Asus WL-500g Premium v.1 || Tomato version v1.27.8741 ND USB Extra
 
shibby
omg i dopiero teraz mowisz o DMZ? to jak ty chcesz zeby ci dzialalo skoro masz kompa w DMZcie. wypuszczasz przed nata kompa i domyslnie wszystkie polaczenia trafiaja do niego. btw po diabla ci komp w dmzcie?
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
fjk8
Nie mow ze to dlatego :| blah nigdy bym na to nie wpadl. Zaraz stestuje czy to pomaga. Komp w dmz zebym nie musial otwierac portow dla kazdej pierdoly ktora chce odpalic.

p.s. tak czulem zeby to posprawdzac z wylaczonym dmz. nie ma mozliwosci polaczenia wlaczonego dmz z innymi otwartymi portami ? Przeciez dzialaja jakos te uslugi ktore mozna wlaczyc na routerze i dostac sie do nich z zewnatrz ? Najchetniej zrobil bym taki prawdziwy dmz jak opisuja na openwrt ale chyba nie podolalbym zadaniu.
Edytowany przez fjk8 dnia 20-04-2009 19:18
Tomato v1.23.0001 SDHC mod
 
fjk8
Dziala. Rzeczywiscie to logiczne, ze tez na to nie wpadlem.....zaraz sproboje wczesniejszych ustawien do amula. Jak jest zrobione remote ssh i remote web adm ?
Tomato v1.23.0001 SDHC mod
 
shibby
tzn jak jak. nie rozumiem pytania?
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
fjk8
Czmu jest problem z dostaniem sie do portu 9091 a nie ma z dostaniem sie do 8080 albo 2222 ? Rozumiem ze jak bym mial na lokalnym kompie httpd na 8080 to mimo dmz tam sie nie dostane ?
Tomato v1.23.0001 SDHC mod
 
rzerzuch
Dobra nie mam już sił walczyć
bez problemu instaluje się optware, transmision i co tam potrzeba, tworze swapa za wczasu wszytko się ładnie montuje po starcie
konfig w moim wykonaniu wygląda tak


{
"blocklist-enabled": 0,
"download-dir": "\/mnt\/disc0_1\/torrent",
"download-limit": 150,
"download-limit-enabled": 1,
"encryption": 1,
"lazy-bitfield-enabled": 1,
"message-level": 2,
"open-file-limit": 32,
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-enabled": 0,
"peer-port-random-high": 65535,
"peer-port-random-low": 1024,
"peer-socket-tos": 0,
"pex-enabled": 1,
"port-forwarding-enabled": 1,
"preallocation": 1,
"proxy": "",
"proxy-auth-enabled": 0,
"proxy-auth-password": "",
"proxy-auth-username": "",
"proxy-enabled": 0,
"proxy-port": 80,
"proxy-type": 0,
"rpc-authentication-required": 1,
"rpc-enabled": 1,
"rpc-password": "admin",
"rpc-port": 9091,
"rpc-username": "admin",
"rpc-whitelist": "127.0.0.1",
"rpc-whitelist-enabled": 0,
"upload-limit": 20,
"upload-limit-enabled": 1,
"upload-slots-per-torrent": 14
}


plik startowy umieszczony w /opt/etc/init.d/ i w katalogu init.d jest plik transmission o tresci


#!/opt/bin/bash

case "$1" in
start)
/opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
;;
stop)
killall -KILL transmission-daemon
;;
*)
echo "Usage: $0 start|stop"
esac


Po wedytowaniu i zapisaniu przez vi wyglądał tak


e "$1" in
start)
/opt/bin/transmission-daemon -g /mnt/disc0_1/torrent
;;
stop)
killall -KILL transmission-daemon
;;
*)
echo "Usage: $0 start|stop"
esac

i teraz jestem głupi jak powinien wyglądać ten plik ???

firewall na chwile obecna wygląda tak


sleep 10
/bin/mount -o bind /tmp/mnt/disc0_1/opt /opt
sleep 5
swapon /tmp/mnt/disc0_1/swap
sleep 5
WANIP=$(nvram get wan_ipaddr)
/opt/etc/init.d/transmission start
iptables -t nat -A PREROUTING -p tcp -d $WANIP --dport 51413 -j DNAT --to 192.168.1.3:51413
iptables -A INPUT -d 192.168.1.3 -p tcp --dport 51413 -j ACCEPT


No i cóż przy probie wejścia na transsmision wywala
"Firefox nie może nawiązać połączenia z serwerem 192.168.1.3:9091"
jakieś pomysły ??

 
shibby
a zamiast odpalac z pliku startowego sprobuj poprostu odpalic go tak

/opt/bin/transmission-daemon -g /mnt/disc0_1/torrent

i zobacz czy masz procesy w ps

troche dziwnie ci wyglada ten plik po wyedytowaniu przez vi...

doinstaluj sobie z optware nano i sprobuj wkleic zawartosc mojego pliku startowego przez nano.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
rzerzuch
Jesteś wielki Grin działa.
Po wklepaniu w konsole transmission się uruchomił, wklejiłem to na koniec firewalla i po restarcie routera transmission elegancko dział, ale automatycznie spadły transfery z i na dysk i mam podobne do twoich.
Tak myślę sobie ze przydało by się coś takiego aby na czas wrzucania czy tez kopiowania plików można by transmission wyłączyć. Tylko jak to zrobić aby było w miarę wygodne
 
obsy
Przyciskiem na urządzeniu? Naciskasz i zamyka transmission, naciskasz i go uruchamia.

Ew skrypt na komputerze który to robi (przez ssh zdalnie).
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
rzerzuch
Dobry pomysł Smile
Można do tego celu wykorzystać któryś z tylnich przycisków asusa??
 
obsy
Pod openwrt tak, pod tomato dowiedź się czy są i jak one obsługiwane.
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
minusem rozwiazania jest to ze transmission dlugo weryfikuje dane po restarcie, obciazajac wtedy procka w 100%, wiec ja sciagam pliki przy dzialajacym transmission.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
obsy
Hasze liczy. wrt wydajnością nie grzeszy.

PS. http://openlinksys.info/forum/viewthr...post_43985

index.html na nasze zrobiłem, jak ktoś chce interfejs po polsku niech po prostu podmieni sobie plik. Dla 1.52.
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
brawa dla tego pana Smile zajebista sprawa B)


btw zaktualizowalem pierwszy post.
Edytowany przez shibby dnia 24-04-2009 12:23
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 4

· Użytkowników online: 0

· Łącznie użytkowników: 24,116
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

shibby
12-02-2024 11:03
MTU zależy od typu połączenia. Inne jest dla połączenia kablowego inne dla wdzwanianego (pppoe)

PanRatio
11-02-2024 10:02
Jak podłączę Funboxa6 do światłowodu, to ma MTU 1540, a we FreshTomato max to MTU 1500 i samo zmienia na 1492. Tak ma być?

tamtosiamto
04-02-2024 10:36
jakby cos, to mam w dobrej cenie dir868l juz przerobiony na AC66U_B1 Grin i ac56u przerobiony na ac68u(dziala aimesh) tyle ze z wlacznikiem na zapalke Smile

Adooni
03-02-2024 10:36
widze ze oba sa na aledrogo i u nas mozesz sprawdzac w dziale sprzedam

Adooni
03-02-2024 10:34
zakladam że mowisz o używkach masz np Asus RT-AC56U, D-Link DIR-868L (jak go nie przerobisz na Asus RT-AC66U_B1) to FT ma specialny build nvram 32k)

vechio
01-02-2024 09:29
Cześć, czy istnieje jakiś 'odpowiednik'
; WNR3500Lv2 z 5GHz i z TYLKO wewnętrznymi antenami + ze wsparciem dla FreshTomato?

tamtosiamto
29-01-2024 21:59
to linux, raczej nie masz tak duzego, ktorego nie obsluzy

RaTaJ
28-01-2024 23:08
Dzień Dobry jaki max dysk USB można podłączyć pod NetGear WNRL3500Lv2?

Adooni
01-01-2024 09:44
Wszystkiego najlepszego w nowym roku. Jaka macie sprawdzoną antenkę do E3372S?

Adooni
25-12-2023 08:34
ja kupilem ale ostatecznie oddalem i wzialem Cudy WR3000. Bardzo dobrze dziala z OpenWRT zabawy jest z wi-fi aby znalesc kanal ktory dziala na 160. Nowyszy HW w porownaniu do x6 i 2 razy mniejszy

69,343,060 unikalnych wizyt