21 Lutego 2024 16:26:17
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Netflix dzielenie ko...
· [MOD] FreshTomato-AR...
· Netgear WNR3500L
· Nextcloud konfigurac...
· [MOD] FreshTomato-MI...
· [MOD] Tomato64 (x86-64)
· [S] ASUS RT-AC68U
· Banana PI (BRI-R3)
· [S]Banana PI (BRI-R3...
· [S] Płyta, Procek, ...
· Czy to atak hakerski ?
· Asus RT-N10U - znany...
· asus rt-n10u problem...
· Konfiguracja adresó...
· Wi-Fi 160MHz
· USB LAN do TV
· RT-N16
· ASUS AX92U bootloop
· Tomato resetuje się...
· swieta
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [862]
· Netgear WNR3500L [737]
· Netflix dzielenie... [12]
· Nextcloud konfigu... [12]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [215 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 415
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
44.210.77.73
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
Serwer DNS w tomato
pumek
Próbuję ustawić serwer DNS na R600v2 i mi nie wychodzi. Od początk, jako główny router jest asus ax55, jako drugi R6400. Ruterki są w jednej puli. Chciało by się skorzystać z możliwości tomato i mieć blockera reklam i szyfrowanie DNS i nie potrafię to poustawiać. Jeśli postawie adguarda na malinie to serwer na nim działa ale nie potrzebna mi w tej chwili malina tylko na dns. Zakładam że na asusie ustawiam dobrze. Jak miałem r64000 jako główny router to blokowanie reklam działało.
Na asusie ustawiam serwer DNS na ip r6400 i dupa brak internetu.
 
qrs
też z tym walczę ;)

moja konfiguracja:
router R7000 na IP 192.168.0.10 (Basic > Network > WAN0 DNS 192.168.0.11)
pihole raspbbery pi na IP 192.168.0.11

Wszystkie urządzenia poza IoT korzystają z tego DNS, niestety odkurzacz, gniazdka i żarówki sterowane nie. Przeszkadza mi to bo łączą się z czymś co śledzi statystyki itp. i nie mogę tego zablokować.

próbowałem w Administration > Scripts > Firewall ustawić


iptables -t nat -A PREROUTING -s 192.168.0.10/24 -p udp -m udp --dport 53 -j DNAT --to-destination 192.168.0.11
iptables -t nat -A PREROUTING -s 192.168.0.10/24 -p tcp -m tcp --dport 53 -j DNAT --to-destination 192.168.0.11
service iptables restart

lub


iptables -t nat -A OUTPUT -p udp --dport 53 -j DNAT --to 192.168.0.11:53
iptables -t nat -A OUTPUT -p tcp --dport 53 -j DNAT --to 192.168.0.11:53
service iptables restart

i w obu przypadkach nie działa, myślę że jestem blisko i to kwestia poprawności składni i IoT odziedziczą mój DNS zamiast domyślnego swojego 8.8.8.8 ;)

Możesz popróbować w ten sposób i może trafisz jak to należy ustawić ;)
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jan49
Dzień dobry,
nie będę zakładał nowego tematu bo sprawa dotyczy konfiguracji freshtomato do połączenia z pi-hole. Walczę trzeci dzień i nie potrafię tego ustawić.
Sprzęt to router Asus RT-N15U, pi-hole na rpi4, gdy ustawię:
Basic > Network > WAN0 DNS >Manual 192.168.1.3 (adres pi-hole) to mogę łączyć się z lokalnymi urządzeniami natomiast brak dostępu na zewnątrz a zapytania w pi-hole rosną jak dług publiczny.
Kolego @qrs proszę napisz jak ty to ustawiłeś, że tobie to działa (nie piszę o IoT)?
 
qrs
w Advanced > DHCP/DNS > Dnsmasq Custom configuration* ustawiłem tylko

dhcp-option=tag:br0,6,192.168.0.11 
(adres pi-hole)

jan49 napisał:

zapytania w pi-hole rosną jak dług publiczny

wyłącz Intercept DNS port bo pewnie masz włączone

* - DHCPC Options nie przyjmuje opcji
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jan49
Serdeczne dzięki za odpowiedź.Smile
Wpis dhcp-option=tag:br0,6,192.168.1.3 to było to! Dzięki raz jeszcze.
Proszę jeszcze jak możesz napisz mi bo chyba namieszałem wcześniej kombinując jak masz ustawione całe Advanced > DHCP/DNS >
bo coś mi na raspberry pi-hole nie blokuje reklam. I czy w pi-hole masz klienta "localhost 127.0.0.1"? Bo w moim przypadku to generuje największy ruch.
 
qrs
mam

Cytat

127.0.0.1 00:00:00:00:00:00
virtual interface lo localhost
ale nie generuje ruchu, pojedyncze strzały jednak występuję, kilka w ciągu dnia.

DHCP server enabled masz wyłączony? Ja tak.

jan49 napisał:

jak masz ustawione całe Advanced > DHCP/DNS >
bo coś mi na raspberry pi-hole nie blokuje reklam


zobacz w załączniku
qrs załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez qrs dnia 10-09-2022 15:17
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jan49
Wszystko przydziela router pi-hole ma tylko blokować.
Napiszę tak udało się zrobić konfigurację po twojej radzie. Wszystkie urządzenia w sieci teraz mają blokadę.
Na jednym z klientów:
-$ nslookup pi.hole
Server: 192.168.1.3
Address 1: 192.168.1.3 pi.hole

Name: pi.hole
Address 1: 192.168.1.3 pi.hole
Address 2: fe80::b4ee:37ae:6b63:6b49 pi.hole

-$ nslookup facebook.com
Server: 192.168.1.3
Address 1: 192.168.1.3 pi.hole

Name: facebook.com
Address 1: 0.0.0.0
Address 2: ::

Zapytania już nie szaleją można powiedzieć jest normalnie. Jedynie dla samego RPI na którym teraz piszę pi-hole nie blokuje.
W /etc/dhcpcd.conf zrobiłem wpis static domain_name_servers=127.0.0.1, ale nic to nie dało.

~ $ nslookup pi.hole
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: pi.hole
Address: 127.0.0.1
Name: pi.hole
Address: ::1
 
qrs
ja jeszcze wyłączyłem IPv6 na DNS mimo, że mam swój zew.
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jan49
Dziękuję kolego za wsparcie.
 
chans
Trochę odkopuję temat: walczę od nie dawna z tematem Netia+tomato+pihole na docker.
PiHole lata na doker, który ma statyczny IP i rozmawia z Tomato. Router posiada następujące wpisy:

Cytat

dhcp-option=tag:br0,6,10.xx.xx.xx


W firewall (chodzi o to aby wszystko przelatywało przez PiHole, nawet jak ma zaszyte własne DNS):

Cytat

iptables -t nat -I PREROUTING -i br0 -p tcp ! -s ipPiHole--dport 53 -j DNAT --to IpPiHole
iptables -t nat -I PREROUTING -i br0 -p udp ! -s IpPiHole --dport 53 -j DNAT --to IpPiHole


Od momentu przejścia do Netii, musiałem zmienić konfigurację WAN w routerze na PPoE. W sekcji WAN wpisany był adres IP LAN PiHole. Niestety podczas zmiany adresu IP WAN traciłem połączenie z internetem, dokładniej lokalny serwer DNS obsługiwany przez PiHole (z wsparciem DoH) przestawał odpowiadać i nie było reakcji na próby wejścia na jakąkolwiek stronę. Dopiero restart docker z PiHole rozwiązywał problem. Obejściem okazało się ustawienie DNS WAN na 1.1.1.1 (czyli DNS zewnętrzny), ale w tym przypadku PiHole w logach widział zapytania tylko z routera a nie od konkretnego urządzenia. Obecnie ustawiłem 2 adresy w DNS: PiHole oraz DNS Zewnętrzny - teoretycznie jest poprawa bo nie zauważam odcinana od internetu, w logach PiHole część zapytań widać od konkretnego urządzenia, ale nie jest to idealne.

Co w tej konfiguracji jest nie tak? Mając UPC nie miałem tego typu problemów więc wnioskuję, że jest to jakoś związane z PPoE i ustawieniem DNS w sekcji WAN. Czy można ustawić inny DNS dla WAN a inny DNS dla LAN? Moze problem jest w regule IpTables która w momencie zmiany adresu IP Wan wpada w pętlę zapytań?
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 32

· Użytkowników online: 0

· Łącznie użytkowników: 24,116
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

shibby
12-02-2024 11:03
MTU zależy od typu połączenia. Inne jest dla połączenia kablowego inne dla wdzwanianego (pppoe)

PanRatio
11-02-2024 10:02
Jak podłączę Funboxa6 do światłowodu, to ma MTU 1540, a we FreshTomato max to MTU 1500 i samo zmienia na 1492. Tak ma być?

tamtosiamto
04-02-2024 10:36
jakby cos, to mam w dobrej cenie dir868l juz przerobiony na AC66U_B1 Grin i ac56u przerobiony na ac68u(dziala aimesh) tyle ze z wlacznikiem na zapalke Smile

Adooni
03-02-2024 10:36
widze ze oba sa na aledrogo i u nas mozesz sprawdzac w dziale sprzedam

Adooni
03-02-2024 10:34
zakladam że mowisz o używkach masz np Asus RT-AC56U, D-Link DIR-868L (jak go nie przerobisz na Asus RT-AC66U_B1) to FT ma specialny build nvram 32k)

vechio
01-02-2024 09:29
Cześć, czy istnieje jakiś 'odpowiednik'
; WNR3500Lv2 z 5GHz i z TYLKO wewnętrznymi antenami + ze wsparciem dla FreshTomato?

tamtosiamto
29-01-2024 21:59
to linux, raczej nie masz tak duzego, ktorego nie obsluzy

RaTaJ
28-01-2024 23:08
Dzień Dobry jaki max dysk USB można podłączyć pod NetGear WNRL3500Lv2?

Adooni
01-01-2024 09:44
Wszystkiego najlepszego w nowym roku. Jaka macie sprawdzoną antenkę do E3372S?

Adooni
25-12-2023 08:34
ja kupilem ale ostatecznie oddalem i wzialem Cudy WR3000. Bardzo dobrze dziala z OpenWRT zabawy jest z wi-fi aby znalesc kanal ktory dziala na 160. Nowyszy HW w porownaniu do x6 i 2 razy mniejszy

69,314,360 unikalnych wizyt